Настройки AnyLogic

Диалоговое окно Настройки AnyLogic позволяет пользователю изменять настройки программы AnyLogic.

  Чтобы открыть диалоговое окно Настройки AnyLogic

  1. Выберите Инструменты > Настройки... из главного меню.
Диалоговое окно содержит несколько страниц:

Страница "Основные"

Страница Основные содержит элементы управления, позволяющие изменять основные настройки программы AnyLogic:


Отображать стартовую страницу при запуске - Если опция выбрана, то при каждом запуске AnyLogic будет отображаться Начальная страница.

Уведомлять о выходе обновлений AnyLogic - Если опция выбрана, то в случае выхода новых обновлений или версий AnyLogic вас будут автоматически уведомлять об этом. Если срок действия вашей лицензии на Сервис технической поддержки еще не истек, то вы сможете скачать и установить обновления с веб сайта. 

Показывать уведомления о новых опросах и анкетах - Если опция выбрана, AnyLogic проверяет, нет ли новых опросов и анкет, и уведомляет пользователя, если таковые имеются.

Папка моделей по умолчанию - Выбранная здесь папка будет использоваться по умолчанию при создании моделей и при их сохранении под новым именем.

Количество недавно открытых моделей в меню Файл - Максимальное количество ссылок для быстрого открытия недавно открытых моделей, отображаемых в подменю Файл > Недавно открытые модели

Включить автосохранение - Если опция выбрана, то AnyLogic будет автоматически сохранять все открытые в рабочем пространстве модели в фоновом режиме, через заданный интервал времени (он задается в расположенном ниже поле Интервал сохранения). Подробнее о механизме автоматического сохранения моделей AnyLogic и их восстановления можно прочесть здесь.

Язык - На данный момент AnyLogic локализован на несколько языков, в том числе и русский (полностью: и интерфейс, и документация). При запуске AnyLogic использует тот язык, который соответствует региональным настройкам операционной системы. Если AnyLogic не локализован на искомый язык, то по умолчанию используется английский язык. При необходимости пользователь может явно сменить язык, выбрав его в данном элементе управления.


Страница "Разработка"

На странице Разработка вы найдете настройки, связанные с разработкой моделей и библиотек. 


Предварительно просматривать результаты переименования - Если опция выбрана, то при каждом переименовании какого-либо элемента модели с помощью команды Переименовать будет показано диалоговое окно, позволяющее пользователю самостоятельно выбирать, какие именно ссылки на переименованный элемент должны быть также переименованы, а какие должны остаться такими же, какими они есть.

Отображать всплывающие подсказки - Если опция выбрана, то при наведении курсора мыши на имя элемента в Палитре и Свойствах будет отображаться всплывающая подсказка с описанием элемента.

Отображать номера строк - Если опция выбрана, то в Java редакторе отображаются номера строк.

Режим разработчика библиотек - Если опция выбрана, то у определенных элементов будут отображены некоторые спрятанные свойства, которые могут быть полезны, только если вы разрабатываете собственную библиотеку.

Создавать наборы данных для динамических переменных - Здесь задается значение по умолчанию свойства Создавать наборы данных для динамических переменных, которое будет использоваться всеми новыми создаваемыми пользователем типами агентов (эта опция находится в секции свойств Специфические).

Скрывать панель Ошибки при отсутствии ошибок - Если опция выбрана, то панель Ошибки будет автоматически скрываться при отсутствии ошибок в модели, иначе же настройки отображения этой панели контролируются пользователем.

Скрывать панель Консоль при завершении работы модели - Если опция выбрана, то панель Консоль будет автоматически скрываться при отсутствии ошибок в модели, иначе же настройки отображения этой панели контролируются пользователем.

Продолжать запуск, если проект содержит ошибки - Группа кнопок, определяющая, будет ли AnyLogic продолжать запуск модели, содержащей ошибки.

Всегда - модель будет запускаться в любом случае.

С подтверждением - в случае обнаружения ошибок при запуске модели будет отображаться диалоговое окно с сообщением об ошибках, позволяющее как продолжить запуск, так и прервать его, вернувшись в режим редактирования модели для исправления ошибок.


Страница "Графический редактор"

Страница Графический редактор свойств AnyLogic содержит настройки среды графического редактора.


Соединение блоков процессных диаграмм - Секция свойств определяет правила создания диаграмм процесса в графическом редакторе.

Соединять автоматически, если порты достаточно близко - Порты блоков диаграмм процессов будут соединяться автоматически, если блоки оказываются поблизости друг с другом в графическом редакторе. Если опция не выбрана, пользователь будет соединять порты вручную.

Разрешить соединение по одиночному щелчку - Порты могут соединяться по одиночному щелчку. Если опция не выбрана, выполните двойной щелчок, чтобы начать рисовать соединитель из порта блока библиотеки.

Удалять крайний соединитель при удалении блока - Выберите эту опцию, если хотите удалять вместе с блоком оставшийся соединитель. 

Изменять масштаб агента при добавлении элементов разметки пространства - Опция определяет, будет ли AnyLogic предлагать пользователю изменить масштаб агента при добавлении в графический редактор элементов разметки пространства, относящихся к Библиотеке дорожного движения или к Железнодорожной библиотеке. 

Автомасштабирование 3D объектов в соответствии с масштабом агента - Опция определяет, будет ли AnyLogic автоматически изменять размер 3D объектов, которые пользователь добавляет в графический редактор, чтобы привести их в соответствие с текущим масштабом агента (к примеру, привести масштаб домов в соответствие с железнодорожными путями, нарисованными на холсте графического редактора).


Страница "Соединение"

На странице Соединение вы можете изменить настройки соединения AnyLogic. Если вы используете прокси, то вам нужно будет выбрать опцию Использовать прокси и ввести корректные значения в полях Http прокси и Порт. При необходимости, введите Логин и Пароль. Если вы используете лицензию для работы групп пользователей, то вы можете активировать AnyLogic здесь, в секции Сервер лицензирования Anylogic.

Если вы используете прокси для выхода в интернет (к примеру, сервер GIS карт), но вам также необходимо обойти прокси, чтобы получить доступ к локальному серверу (к примеру, сервер баз данных), вы можете указать имя локального сервера в перечне Не использовать прокси для адресов, начинающихся с (см. изображение ниже). В этом перечне можно указать несколько адресов через точку с запятой.



Страница "Клавиши"

На странице Клавиши вы можете изменять "быстрые клавиши", назначенные программой для некоторых команд. Приведенная на этой странице таблица приводит список всех таких команд и назначенных им комбинаций "быстрых клавиш".
Сейчас она может изменить комбинацию клавиш для автоматической подстановки кода .


 Чтобы задать новую комбинацию "быстрых клавиш" для команды

  1. Выделите ту строку таблицы, которая хранит настройки для нужной вам команды.
  2. Щелкните мышью в поле Комбинация клавиш и нажмите на клавиатуре ту комбинацию клавиш, которую вы хотите сделать "быстрыми клавишами" для данной команды.

Страница "Выполнение модели"

На странице свойств Выполнение модели вы можете настроить отображение диаграмм процессов и количество процессоров при запуске модели.


Показывать счетчики у блоков диаграмм процессов - Если опция выбрана, счетчики будут показываться около иконок блоков (отображая количество агентов внутри блока, количество агентов, которые вошли в блок и т.д.), см. рисунок ниже.

Показывать анимацию портов блоков диаграмм процессов - Если опция выбрана, то состояния портов библиотечных блоков будут анимироваться во время моделирования. Если в порту будут находиться агенты, ожидающие перехода в следующий блок диаграммы процесса, то такой порт будет подсвечиваться темно-оранжевым цветом (см. рисунок ниже).

Количество процессоров для параллельных вычислений - Если процессор вашего компьютера имеет несколько ядер, то при запуске эксперимента оптимизации или варьирования параметров AnyLogic может параллельно выполнять сразу несколько итераций эксперимента на различных ядрах процессора. Таким образом может быть достигнуто многократное увеличение производительности. Здесь вы можете задать количество процессоров, которое AnyLogic сможет использовать для параллельного выполнения "прогонов" модели.


Страница "База данных"

Страница База данных содержит настройки встроенной базы данных AnyLogic.


Показывать предупреждения о потере данных - Если опция выбрана, будут появляться предупреждения, в случае потери данных.

Показывать предупреждения о потере данных - Если опция выбрана, будут появляться предупреждения о потенциальной потере данных.

Показывать вопросы базы данных - Если опция выбрана, пользователь будет видеть вопросы, генерируемые базой данных.

Отображать столбец с идентификаторами записей таблицы "al_id" - Если опция выбрана, скрытый столбец с идентификаторами записей al_id станет видимым в редакторе таблиц БД. Этот столбец содержит уникальные идентификаторы для записей таблицы.

Удалять лог модели перед фиксацией изменений в хранилище SVN - Если вы используете SVN и фиксируете в нем изменения своих моделей, в этом параметре вы можете указать, стоит ли вместе с моделью фиксировать лог модели.

Таймаут соединения - Здесь задается таймаут соединения с базой данных (в секундах).


Страница "Дополнительные"

Наконец, вы найдете Дополнительные настройки AnyLogic на последней странице. 


Отображать состояние "кучи" памяти (Изменение параметра требует перезапуска приложения) - Если опция выбрана, то состояние "кучи" Java памяти будет отображаться в строке состояния AnyLogic.

Включить шейдеры AnyLogic для освещения и отображения сетки - Если опция выбрана, то AnyLogic будет использовать шейдеры для освещения сетки, что сделает сцену трехмерной анимации более привлекательной. Обратите внимание: определенное аппаратное обеспечение может не поддерживать шейдеры.

Кнопка Запустить (F5) - Здесь вы можете выбрать, какой эксперимент запускается по умолчанию при нажатии кнопки Запустить панели инструментов или кнопки F5 на вашей клавиатуре: кнопка запускает либо эксперимент последней созданной или открытой модели, либо последний запущенный эксперимент.