Меню AnyLogic

Главное меню AnyLogic состоит из следующих меню:

Меню Файл

Меню Файл содержит команды основных операций AnyLogic.

Создать - Команда создания нового элемента. Открывает контекстное меню, в котором нужно будет выбрать тип элемента, который вы хотите создать (модель, тип агента, Java интерфейс, Java класс, размерность, эксперимент или библиотека).

Открыть... - Открывает ранее созданную модель.

Недавно открытые модели - Позволяет открыть одну из ранее открытых моделей (открывает список ранее открытых моделей, открыть модель можно щелчком по ее имени). Максимальное количество моделей в списке задается в настройках AnyLogic.

Сохранить - Сохраняет все несохраненные изменения в выбранной в текущий момент модели.

Сохранить как... - Сохраняет выбранную в текущий момент модель под другим именем.

Сохранить все - Сохраняет все открытые модели.

Закрыть - Закрывает выбранную в текущий момент модель.

Закрыть другие - Закрывает все модели кроме выбранной в текущий момент времени.

Закрыть все - Закрывает все открытые модели.

Импорт - Содержит команды импорта моделей AnyLogic:

Из Vensim - Импортирует модель из Vensim.

Экспорт - Содержит команды экспорта модели:

В облако AnyLogic - Экспортирует выбранную в текущий момент времени модель в облако AnyLogic.

В отдельное Java приложение - Экспортирует выбранную в текущий момент времени модель как отдельное приложение Java (опция доступна только в AnyLogic Professional).

 Обучение ИИ — Экспортирует выбранную в текущий момент времени модель и содержащийся в ней Эксперимент обучения ИИ на платформу для обучения ИИ.

SVN - Содержит команды для совместной разработки моделей в командах с помощью SVN (доступно только в AnyLogic Professional).

Забрать из SVN - забирает модель из хранилища SVN, создает ее локальную рабочую копию.

Добавить... - добавляет выбранную в данный момент модель в хранилище SVN.

Зафиксировать... - вносит локальные изменения в хранилище SVN.

Обновить... - обновляет локальную рабочую копию модели последними изменениями из хранилища SVN.

Выход - Завершает работу AnyLogic.

Меню Правка

Меню Правка содержит часто используемые команды редактирования модели.

Отменить - Отменяет последнее совершенное действие.
Повторить - Повторяет выполнение только что отмененного действия.
Вырезать - Вырезает выделенные в текущий момент времени элементы (или фрагменты кода/свойств).
Копировать - Копирует выделенные в текущий момент элементы (или фрагменты кода/свойств) в Буфер обмена.
Копировать как изображение - Копирует изображение выделенных в текущий момент элементов в Буфер обмена.
Вставить - Вставляет содержимое Буфера обмена в текущий контекст.
Удалить - Удаляет выделенные в текущий момент времени элементы (или фрагменты кода/свойств).
Выбрать все - Выделяет все в активном в данный момент времени редакторе или панели.
Поиск... - Производит поиск заданной строки текста в рабочем пространстве AnyLogic (или в выбранных моделях/элементах моделей) и опционально производит замену всех найденных строк заданными строками.

Меню Вид

Меню Вид содержит команды управления панелями и редакторами AnyLogic:

Проекты - Открывает/закрывает панель Проекты.

Свойства - Открывает/закрывает панель Свойства.

Палитра - Открывает/закрывает панель Палитра.

Консоль - Открывает/закрывает панель Консоль.

Ошибки - Открывает/закрывает панель Ошибки.

Поиск - Открывает/закрывает панель Поиск.

Результаты ГИС поиска - Открывает/закрывает панель Результаты ГИС поиска.

Отладка - Открывает/закрывает панель Отладка.*

Точки останова - Открывает/закрывает панель Точки останова.*

Переменные - Открывает/закрывает панель Переменные.*

Выражения - Открывает/закрывает панель Выражения.*

Журнал - Открывает/закрывает панель Журнал.

* Этот пункт меню доступен только в AnyLogic Professional иAnyLogic University Researcher.

Меню Рисование

Меню Рисование содержит команды, используемые во время работы с графическим редактором. Это меню видно только тогда, когда графический редактор открыт.

Порядок

На передний план - Изменяет порядок отображения фигур при их наложении, а именно перемещает выделенную фигуру на передний план.

Переместить вперед - Изменяет порядок отображения фигур при их наложении, а именно перемещает выделенную фигуру на один уровень вперед.

Переместить назад - Изменяет порядок отображения фигур при их наложении, а именно перемещает выделенную фигуру на один уровень назад.

На задний план - Изменяет порядок отображения фигур при их наложении, а именно перемещает выделенную фигуру на задний план.

Группировка

Разгруппировать - Разгруппировывает фигуры той группы, в которую входит выделенная на момент вызова команды фигура.

Выделить содержимое группы - Выделяет все содержимое группы, в которую входит выделенная на момент вызова команды фигура.

Создать группу - Создает новую группу и добавляет в нее выделенные фигуры.

Добавить в существующую группу - Добавляет выделенные фигуры в одну из существующих групп (после вызова этой команды эту группу нужно будет указать, щелкнув мышью по ее значку в графическом редакторе).

Удалить из группы - Удаляет выделенные фигуры из группы.

Масштаб

100% - Устанавливает первоначальный масштаб отображения диаграммы (100%).

Отдалить - Уменьшает масштаб отображения диаграммы, как бы "отдаляя" ее содержимое.

Приблизить - Увеличивает масштаб отображения диаграммы, как бы "приближая" ее содержимое.

Сетка

Включить/отключить сетку - Включает либо отключает сетку диаграммы.

Отобразить/спрятать сетку - Отображает либо прячет сетку диаграммы.

Отобразить/спрятать оси - Отображает либо прячет координатные оси.

Выравнивание

По левому краю - Выравнивает все выделенные элементы своими левыми границами по левому краю того выделенного элемента, который располагается левее всех.

По горизонтальному центру - Смещает каждую выделенную фигуру по горизонтали так, чтобы ее центр находился на вертикальной оси, проходящей через центр выделенной области.

По правому краю - Выравнивает все выделенные элементы своими правыми границами по правому краю того выделенного элемента, который располагается правее всех.

По верхнему краю - Выравнивает все выделенные элементы своими верхними границами по верхнему краю того выделенного элемента, который располагается выше всех.

По вертикальному центру - Смещает каждую выделенную фигуру по вертикали так, чтобы ее центр находился на горизонтальной оси, проходящей через центр выделенной области.

По нижнему краю - Выравнивает все выделенные элементы своими нижними границами по нижнему краю того выделенного элемента, который располагается ниже всех.

Спрятать группу элементов - Содержит команды, позволяющие скрывать и отображать фигуры одного типа в графическом редакторе. Когда фигуры скрыты, они становятся полупрозрачными, недоступными пользователю для выбора.

Спрятать элементы разметки пространства - Скрывает/Отображает все элементы разметки пространства на активной в данный момент графической диаграмме.
Спрятать фигуры - Скрывает/Отображает все фигуры презентации на активной в данный момент графической диаграмме.
Спрятать связи системной динамики - Скрывает/Отображает все связи Системной Динамики на активной в данный момент графической диаграмме.
Спрятать 2D фигуры - Скрывает/Отображает 2D фигуры (все фигуры, у которых отмечен пункт Отображать в: Только в 2D в секции свойств Специфические ).
Спрятать 3D фигуры - Скрывает/Отображает все 3D фигуры(все фигуры, у которых в разделе свойств Специфические, в пункте Отображать в указано либо В 2D и 3D, либо Только в 3D).

Меню Модель

Меню Модель содержит основные команды для работы с моделями.

Построить - Осуществляет построение выбранной в данный момент модели.
Запустить - Запускает выбранный из выпадающего списка эксперимент.
Отладка - Запускает отладку выбранного из выпадающего списка эксперимента.*

Продолжить - Продолжает приостановленное отладочное выполнение модели.*

Пропустить функцию - Производит выполнение выбранной в данный момент строки кода. Выполнение приостанавливается на следующей выполняемой строке.*

Трассировать функцию - Вызывает метод, оператор вызова которого находится на выбранной в текущий момент времени строке кода. Выполнение приостанавливается на первой выполняемой строке этого метода.*

Пропустить до оператора возврата - Возобновляет приостановленное отладочное выполнение модели до тех пор, пока не будет выполнено следующее выражение return в текущем методе, после чего выполнение будет приостановлено на следующей выполняемой строке.*

Остановить - Прекращает выполнение запущенной модели.

* - все команды отладки доступны только в AnyLogic Professional.

Меню Инструменты

Создать документацию - Создает документ с описанием всех элементов выбранной в данный момент модели. Поддерживаются документы всех широко используемых форматов: DOCX, PDF, HTML. Элементы в документе разделены на логические группы (диаграммы состояний, диаграммы потоков и накопителей и т.д.). Для каждого элемента приведен список всех его измененных свойств и описание.

Проверить возможность сохранения состояния - Проверяет, поддерживает ли выбранная модель сохранение своего состояния (опция доступна только в AnyLogic Professional).

Проверить единицы измерения сист. динамики - Проверяет правильность задания единиц измерения системной динамики в выбранной модели. Если не выбрана ни одна модель, то проверяет правильность во всех открытых в рабочем пространстве моделях.

Восстановить расположение панелей - Восстанавливает принятые по умолчанию настройки расположения панелей, редактора и панелей инструментов. Данная команда может быть полезна, например, в том случае, если пользователь в результате своей деятельности расположил панели неудобным образом, и хочет вернуться к первоначальным настройкам (когда панель Проекты прикреплена к левому края окна AnyLogic, панель Свойства - к нижнему, Палитра - к правому и т.д.).

Настройки... - Открывает диалоговое окно Настройки AnyLogic , предоставляющее пользователю возможность изменить основные настройки AnyLogic в соответствии со своими предпочтениями.

Меню Справка

Меню Справка содержит команды, предоставляющие доступ к справочной информации, позволяющие проверить наличие на веб сайте обновлений программы, обратиться за помощью к Службе технической поддержки AnyLogic, а также активировать программу и узнать информацию о текущей лицензии.

Справка AnyLogic - Открывает справочную документацию в окне Справка.

Начальная страница - Открывает Начальную страницу AnyLogic.

Примеры моделей - Открывает страницу Примеры моделей Начальной страницы. Эта страница содержит ссылки на все примеры моделей, поставляемые вместе с AnyLogic.

История изменений - Открывает в текстовом редакторе файл, в котором подробно описана история всех изменений в AnyLogic (на английском языке).

Обратиться за помощью... - * Открывает диалоговое окно Техническая поддержка AnyLogic, в котором вы сможете задать вопрос Службе технической поддержки AnyLogic.

Задать вопрос на Stack Overflow - ** Открывает в браузере пользователя страницу c сообщениями под тэгом AnyLogic в Stack Overflow. В качестве альтернативы Технической поддержки AnyLogic, доступной владельцам версий Professional и University Researcher, пользователи версии PLE могут воспользоваться поддержкой сообщества в Stack Overflow.

Тренинги... - Открывает страницу веб сайта компании AnyLogic с информацией о предстоящих обучающих курсах (тренингах) по AnyLogic.

Продлить лицензию на обновления и техподдержку - *Позволяет оформить заказ на продление срока действия лицензии на использование обновлений и технической поддержки AnyLogic. В используемом вами веб-браузере открывается страница с информацией о стоимости продления лицензии для имеющихся у пользователя продуктов AnyLogic и формой для оплаты.

Обновить USB ключ... - * Открывает диалоговое окно, в котором вы можете загрузить файл обновлений ("прошивку") для USB ключа активации AnyLogic. Это действие необходимо выполнить, чтобы завершить процедуру продления лицензии на использование Сервиса технической поддержки, если ваш AnyLogic активирован с помощью USB-ключа.

Проверить наличие обновлений - * Соединяется с сервером Компании ЭниЛоджик и проверяет, есть ли доступные обновления AnyLogic.

Активировать продукт... - Открывает мастер активации,предлагающий провести активацию программы.

Условия использования - Открывает в браузере пользователя документ с условиями лицензирования программного обеспечения.

О программе AnyLogic - Отображает информацию об AnyLogic: тип лицензии, номер версии, срок истечения лицензии, статус Сервисов поддержки и т.д.

* Доступно только в AnyLogic Professional и AnyLogic University Researcher.

** Доступно только в версии AnyLogic PLE.