Панель Проекты

Панель Проекты обеспечивает легкую навигацию по элементам моделей, открытых в текущий момент времени. Поскольку модель организована иерархически, то она отображается в виде дерева: сама модель образует верхний уровень дерева; эксперименты, типы агентов и Java классы образуют следующий уровень; элементы, входящие в состав агентов, вложены в соответствующую подветвь дерева типа агентов и т.д.

Панель Проекты по умолчанию прикреплена к левой части рабочей области AnyLogic.


Панель Проекты

Чтобы открыть/закрыть панель Проекты

  1. Выберите Вид > Проекты из главного меню.

Работа с элементами дерева

AnyLogic поддерживает набор стандартных операций (копирование, удаление и т.д.) по работе с элементами дерева, отображаемого в панели Проекты. Вы можете копировать, перемещать и удалять любые элементы дерева элементов модели, легко управляя, таким образом, вашей рабочей моделью. При копировании и удалении элементов их следует предварительно выбрать.

Чтобы выбрать элемент

  1. Щелкните мышью по элементу.
    Свойства выбранного элемента будут отображены в панели Свойства (если она открыта).

Чтобы удалить элемент

  1. Нажмите на кнопку панели инструментов Удалить, или
    Выберите Правка > Удалить из главного меню, или
    Щелкните правой кнопкой мыши по элементу и выберите Удалить из контекстного меню, или
    Нажмите Del.

Чтобы скопировать элемент

  1. Нажмите на кнопку панели инструментов Копировать, или
    Выберите Правка > Копировать из главного меню, или
    Щелкните правой кнопкой мыши по элементу и выберите Копировать из контекстного меню, или
    Нажмите Ctrl C (Mac OS: Cmd C).

Чтобы вырезать элемент

  1. Нажмите на кнопку панели инструментов Вырезать, или
    Выберите Правка > Вырезать из главного меню, или
    Щелкните правой кнопкой мыши по элементу и выберите Вырезать из контекстного меню, или
    Нажмите Ctrl X (Mac OS: Cmd X).

Чтобы вставить элемент

  1. Выберите родительский элемент, в который вы хотите поместить этот элемент.
    Например, вы можете вставить тип агента в модель.

  2. Выберите Правка > Вставить из главного меню, или
    Щелкните правой кнопкой мыши по родительскому элементу и выберите Вставить из контекстного меню, или
    Нажмите Ctrl V (Mac OS: Cmd V).

Полужирным шрифтом в дереве выделяется тот элемент, редактор которого (графический или Java) активен в текущий момент.

При открытии или создании новой модели в дерево будет автоматически добавляться дерево элементов этой модели. По умолчанию модель содержит только один тип агента и один простой эксперимент. По мере развития модели добавляются новые элементы и растет дерево ее элементов.

Если вы внесете в модель какие-то изменения и не сохраните их, то такая модель будет сразу же выделена в дереве - к имени модели с несохраненными изменениями будет с помощью звездочки (*).

Вы можете разворачивать и сворачивать ветви дерева элементов модели с помощью кнопок и , отображаемых слева от названия ветви дерева элементов.

Чтобы свернуть все открытые ветки дерева моделей в панели Проекты

  1. Щелкните правой кнопкой мыши по любому элементу дерева и выберите Свернуть все из контекстного меню.

Вы можете заметить, что один элемент дерева проектов (это может быть тип агента, эксперимент, Java класс, Java интерфейс или библиотека) может быть выделен жирным цветом. Это означает, что в данный момент открыт редактор именно этого элемента (чаще всего это графический редактор типа агента или эксперимента). Это может быть полезно в таких ситуациях, когда, например, в вашем рабочем пространстве открыто сразу несколько моделей, в каждой из которых есть агент Main, и вы не знаете, диаграмма какого именно типа агента Main открыта в данный момент времени в графическом редакторе:


См. также

Работа с панелями